Server SMB 2.xxx Driver (srv2) Service Defaults in Windows 11
Enables connectivity from Windows Vista and later clients.
Default Settings
| Startup type: | Manual |
| Display name: | Server SMB 2.xxx Driver |
| Service name: | srv2 |
| Service type: | filesys |
| Error control: | normal |
| Group: | Network |
| Path: | %SystemRoot%\System32\DRIVERS\srv2.sys |
| Registry key: | HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\srv2 |
Default Behavior
Server SMB 2.xxx Driver is a file system driver. In Windows 11 it starts only if the user, an application or another service starts it. If Server SMB 2.xxx Driver fails to start, the failure details will be recorded into Event Log. Then Windows 11 should boot up and notify the user about the srv2 service startup failure.
Dependencies
Server SMB 2.xxx Driver cannot be started, if the Srvnet service won't start.
If Server SMB 2.xxx Driver doesn't work properly, the Server service can't start.
Restore Default Startup Configuration of Server SMB 2.xxx Driver
Before you begin doing this, make sure that all the services on which Server SMB 2.xxx Driver depends are configured by default and function properly. See the list of dependencies above.1. Run the Command Prompt as an administrator.
2. Copy the command below, paste it into the command window and press ENTER:
sc config srv2 start= demand
3. Close the command window and restart the computer.
The srv2 service is using the srv2.sys file that is located in the C:\Windows\System32\DRIVERS directory. If the file is removed or corrupted, read this article to restore its original version from Windows 11 installation media.