Server (LanmanServer) Service Defaults in Windows 11
Supports file, print, and named-pipe sharing over the network for your computer. If this service is stopped, these functions will be unavailable. If this service is disabled, any services that explicitly depend on it will fail to start.
Default Settings
| Startup type: | Automatic |
| Display name: | Server |
| Service name: | LanmanServer |
| Service type: | share |
| Error control: | normal |
| Object: | LocalSystem |
| Path: | %SystemRoot%\system32\svchost.exe -k netsvcs -p |
| File: | %SystemRoot%\system32\srvsvc.dll |
| Registry key: | HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer |
| Privileges: |
|
Default Behavior
Server is a Win32 service. In Windows 11 it starts automatically during the operating system startup. Then the Server service logs on as LocalSystem and running in a shared process of svchost.exe. If Server fails to start, the failure details will be recorded into Event Log. Then Windows 11 should boot up and notify the user about the LanmanServer service startup failure.
Dependencies
Server cannot be started, if the following services won't start:
If Server doesn't work properly, the Computer Browser service can't start.
Restore Default Startup Configuration of Server
Before you begin doing this, make sure that all the services on which Server depends are configured by default and function properly. See the list of dependencies above.1. Run the Command Prompt as an administrator.
2. Copy the commands below, paste them into the command window and press ENTER:
sc config LanmanServer start= auto
sc start LanmanServer
3. Close the command window and restart the computer.
The LanmanServer service is using the srvsvc.dll file that is located in the C:\Windows\system32 directory. If the file is removed or corrupted, read this article to restore its original version from Windows 11 installation media.