Hyper-V Data Exchange Service (vmickvpexchange) Defaults in Windows 8
Provides a mechanism to exchange data between the virtual machine and the operating system running on the physical computer.
Default Settings
| Startup type: | Manual |
| Display name: | Hyper-V Data Exchange Service |
| Service name: | vmickvpexchange |
| Service type: | share |
| Error control: | normal |
| Object: | LocalSystem |
| Path: | %SystemRoot%\system32\svchost.exe -k LocalSystemNetworkRestricted |
| File: | %SystemRoot%\System32\ICSvc.dll |
| Registry key: | HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\vmickvpexchange |
| Privileges: |
|
Default Behavior
Hyper-V Data Exchange Service is a Win32 service. In Windows 8 it will not be started until the user starts it. When the Hyper-V Data Exchange Service is started, it runs as LocalSystem in a process of svchost.exe, sharing it with other services. If Hyper-V Data Exchange Service fails to start, the error details are added to Windows 8 error log. When the operating system startup is complete, the user is being notified that the vmickvpexchange service hasn't been started.
Restore Default Startup Configuration of Hyper-V Data Exchange Service
1. Run the Command Prompt as an administrator.
2. Copy the command below, paste it into the command window and press ENTER:
sc config vmickvpexchange start= demand
3. Close the command window and restart the computer.
The vmickvpexchange service is using the ICSvc.dll file that is located in the C:\Windows\System32 directory. If the file is removed or corrupted, read this article to restore its original version from Windows 8 installation media.