Adaptec SAS/SATA-II RAID Storport's Miniport Driver (arcsas) Service Defaults in Windows 8
Adaptec SAS RAID WS03 Driver by PMC-Sierra, Inc.
Default Settings
| Startup type: | Manual |
| Display name: | Adaptec SAS/SATA-II RAID Storport's Miniport Driver |
| Service name: | arcsas |
| Service type: | kernel |
| Error control: | normal |
| Group: | SCSI miniport |
| Path: | %SystemRoot%\System32\drivers\arcsas.sys |
| Registry key: | HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\arcsas |
Default Behavior
The Adaptec SAS/SATA-II RAID Storport's Miniport Driver service is a kernel device driver. In Windows 8 it will not be started until the user starts it. If Adaptec SAS/SATA-II RAID Storport's Miniport Driver fails to start, the error details are added to Windows 8 error log. When the operating system startup is complete, the user is being notified that the arcsas service hasn't been started.
Restore Default Startup Configuration of Adaptec SAS/SATA-II RAID Storport's Miniport Driver
1. Run the Command Prompt as an administrator.
2. Copy the command below, paste it into the command window and press ENTER:
sc config arcsas start= demand
3. Close the command window and restart the computer.
The arcsas service is using the arcsas.sys file that is located in the C:\Windows\System32\drivers directory. If the file is removed or corrupted, read this article to restore its original version from Windows 8 installation media.