Diagnostic System Host (WdiSystemHost) Service Defaults in Windows 11
The Diagnostic System Host is used by the Diagnostic Policy Service to host diagnostics that need to run in a Local System context. If this service is stopped, any diagnostics that depend on it will no longer function.
Default Settings
| Startup type: | Manual |
| Display name: | Diagnostic System Host |
| Service name: | WdiSystemHost |
| Service type: | share |
| Error control: | normal |
| Object: | LocalSystem |
| Path: | %SystemRoot%\System32\svchost.exe -k LocalSystemNetworkRestricted -p |
| File: | %SystemRoot%\system32\wdi.dll |
| Registry key: | HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WdiSystemHost |
| Privileges: |
|
Default Behavior
Diagnostic System Host is a Win32 service. In Windows 11 it starts only if the user, an application or another service starts it. When the Diagnostic System Host service is started, it logs on as LocalSystem and running in a shared process of svchost.exe. If Diagnostic System Host fails to start, the failure details will be recorded into Event Log. Then Windows 11 should boot up and notify the user about the WdiSystemHost service startup failure.
Restore Default Startup Configuration of Diagnostic System Host
1. Run the Command Prompt as an administrator.
2. Copy the command below, paste it into the command window and press ENTER:
sc config WdiSystemHost start= demand
3. Close the command window and restart the computer.
The WdiSystemHost service is using the wdi.dll file that is located in the C:\Windows\system32 directory. If the file is removed or corrupted, read this article to restore its original version from Windows 11 installation media.