Dynamic Volume Manager (volmgrx) Service Defaults in Windows 11

Extension of the volume manager driver that manages software RAID volumes (spanned, striped, mirrored, RAID-5) on dynamic disks.

Default Settings

Startup type: Boot
Display name:Dynamic Volume Manager
Service name:volmgrx
Service type:kernel
Error control:critical
Group:System Bus Extender
Path:%SystemRoot%\System32\drivers\volmgrx.sys
Registry key:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\volmgrx

Default Behavior

Dynamic Volume Manager is a kernel driver. In Windows 11 it starts by the operating system Boot Loader before the Kernel initialization, as a part of the driver stack. If Dynamic Volume Manager fails to start, Windows 11 tries to record the error details into Event Log and restart the PC, using the Last Known Good configuration. If the Last Known Good configuration can't be used, Windows 11 startup process halts with a Stop error. If you disable or delete the volmgrx service, Windows 11 won't start.

Restore Default Startup Configuration of Dynamic Volume Manager

1. Run the Command Prompt as an administrator.

2. Copy the commands below, paste them into the command window and press ENTER:

sc config volmgrx start= boot
sc start volmgrx

3. Close the command window and restart the computer.

The volmgrx service is using the volmgrx.sys file that is located in the C:\Windows\System32\drivers directory. If the file is removed or corrupted, read this article to restore its original version from Windows 11 installation media.