Hyper-V Guest Shutdown Service (vmicshutdown) Defaults in Windows 11
Provides a mechanism to shut down the operating system of this virtual machine from the management interfaces on the physical computer.
Default Settings
| Startup type: | Manual |
| Display name: | Hyper-V Guest Shutdown Service |
| Service name: | vmicshutdown |
| Service type: | share |
| Error control: | normal |
| Object: | LocalSystem |
| Path: | %SystemRoot%\system32\svchost.exe -k LocalSystemNetworkRestricted -p |
| File: | %SystemRoot%\System32\icsvc.dll |
| Registry key: | HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\vmicshutdown |
| Privileges: |
|
Default Behavior
Hyper-V Guest Shutdown Service is a Win32 service. In Windows 11 it starts only if the user, an application or another service starts it. When the Hyper-V Guest Shutdown Service is started, it logs on as LocalSystem and running in a shared process of svchost.exe. If Hyper-V Guest Shutdown Service fails to start, the failure details will be recorded into Event Log. Then Windows 11 should boot up and notify the user about the vmicshutdown service startup failure.
Restore Default Startup Configuration of Hyper-V Guest Shutdown Service
1. Run the Command Prompt as an administrator.
2. Copy the command below, paste it into the command window and press ENTER:
sc config vmicshutdown start= demand
3. Close the command window and restart the computer.
The vmicshutdown service is using the icsvc.dll file that is located in the C:\Windows\System32 directory. If the file is removed or corrupted, read this article to restore its original version from Windows 11 installation media.