Hyper-V Remote Desktop Virtualization Service (vmicrdv) Defaults in Windows 11

Provides a platform for communication between the virtual machine and the operating system running on the physical computer.

Default Settings

Startup type: Manual
Display name:Hyper-V Remote Desktop Virtualization Service
Service name:vmicrdv
Service type:share
Error control:normal
Object:LocalSystem
Path:%SystemRoot%\system32\svchost.exe -k ICService -p
File:%SystemRoot%\System32\icsvcext.dll
Registry key:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\vmicrdv
Privileges:
  • SeChangeNotifyPrivilege
  • SeBackupPrivilege
  • SeRestorePrivilege
  • SeTakeOwnershipPrivilege
  • SeManageVolumePrivilege
  • SeCreateSymbolicLinkPrivilege
  • SeShutdownPrivilege

Default Behavior

Hyper-V Remote Desktop Virtualization Service is a Win32 service. In Windows 11 it starts only if the user, an application or another service starts it. When the Hyper-V Remote Desktop Virtualization Service is started, it logs on as LocalSystem and running in a shared process of svchost.exe. If Hyper-V Remote Desktop Virtualization Service fails to start, the failure details will be recorded into Event Log. Then Windows 11 should boot up and notify the user about the vmicrdv service startup failure.

Restore Default Startup Configuration of Hyper-V Remote Desktop Virtualization Service

1. Run the Command Prompt as an administrator.

2. Copy the command below, paste it into the command window and press ENTER:

sc config vmicrdv start= demand

3. Close the command window and restart the computer.

The vmicrdv service is using the icsvcext.dll file that is located in the C:\Windows\System32 directory. If the file is removed or corrupted, read this article to restore its original version from Windows 11 installation media.