Microsoft Hyper-V Guest Infrastructure Driver (vmgid) Service Defaults in Windows 11
Default Settings
| Startup type: | Manual |
| Display name: | Microsoft Hyper-V Guest Infrastructure Driver |
| Service name: | vmgid |
| Service type: | kernel |
| Error control: | normal |
| Path: | %SystemRoot%\System32\drivers\vmgid.sys |
| Registry key: | HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\vmgid |
Default Behavior
Microsoft Hyper-V Guest Infrastructure Driver is a kernel driver. In Windows 11 it starts only if the user, an application or another service starts it. If Microsoft Hyper-V Guest Infrastructure Driver fails to start, the failure details will be recorded into Event Log. Then Windows 11 should boot up and notify the user about the vmgid service startup failure.
Dependencies
If Microsoft Hyper-V Guest Infrastructure Driver doesn't work properly, the Hyper-V Time Synchronization Service cannot start.
Restore Default Startup Configuration of Microsoft Hyper-V Guest Infrastructure Driver
1. Run the Command Prompt as an administrator.
2. Copy the command below, paste it into the command window and press ENTER:
sc config vmgid start= demand
3. Close the command window and restart the computer.
The vmgid service is using the vmgid.sys file that is located in the C:\Windows\System32\drivers directory. If the file is removed or corrupted, read this article to restore its original version from Windows 11 installation media.