Storage Tiers Management (TieringEngineService) Service Defaults in Windows 11
Optimizes the placement of data in storage tiers on all tiered storage spaces in the system.
Default Settings
| Startup type: | Manual |
| Display name: | Storage Tiers Management |
| Service name: | TieringEngineService |
| Service type: | own |
| Error control: | normal |
| Object: | localSystem |
| Path: | %SystemRoot%\system32\TieringEngineService.exe |
| Registry key: | HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TieringEngineService |
Default Behavior
Storage Tiers Management is a Win32 service. In Windows 11 it starts only if the user, an application or another service starts it. When the Storage Tiers Management service is started, it logs on as localSystem and running in its own process of TieringEngineService.exe. If Storage Tiers Management fails to start, the failure details will be recorded into Event Log. Then Windows 11 should boot up and notify the user about the TieringEngineService service startup failure.
Restore Default Startup Configuration of Storage Tiers Management
1. Run the Command Prompt as an administrator.
2. Copy the command below, paste it into the command window and press ENTER:
sc config TieringEngineService start= demand
3. Close the command window and restart the computer.
The TieringEngineService service is using the TieringEngineService.exe file that is located in the C:\Windows\system32 directory. If the file is removed or corrupted, read this article to restore its original version from Windows 11 installation media.