Microsoft Hyper-V Storage Accelerator (storflt) Service Defaults in Windows 11

Default Settings

Startup type: Manual
Display name:Microsoft Hyper-V Storage Accelerator
Service name:storflt
Service type:kernel
Error control:normal
Group:Extended Base
Path:%SystemRoot%\System32\drivers\vmstorfl.sys
Registry key:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storflt

Default Behavior

Microsoft Hyper-V Storage Accelerator is a kernel driver. In Windows 11 it starts only if the user, an application or another service starts it. If Microsoft Hyper-V Storage Accelerator fails to start, the failure details will be recorded into Event Log. Then Windows 11 should boot up and notify the user about the storflt service startup failure.

Restore Default Startup Configuration of Microsoft Hyper-V Storage Accelerator

1. Run the Command Prompt as an administrator.

2. Copy the command below, paste it into the command window and press ENTER:

sc config storflt start= demand

3. Close the command window and restart the computer.

The storflt service is using the vmstorfl.sys file that is located in the C:\Windows\System32\drivers directory. If the file is removed or corrupted, read this article to restore its original version from Windows 11 installation media.