Microsoft Storage Spaces SMP (smphost) Service Defaults in Windows 11
Host service for the Microsoft Storage Spaces management provider. If this service is stopped or disabled, Storage Spaces cannot be managed.
Default Settings
| Startup type: | Manual |
| Display name: | Microsoft Storage Spaces SMP |
| Service name: | smphost |
| Service type: | own |
| Error control: | normal |
| Object: | NT AUTHORITY\NetworkService |
| Path: | %SystemRoot%\System32\svchost.exe -k smphost |
| File: | %SystemRoot%\System32\smphost.dll |
| Registry key: | HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\smphost |
Default Behavior
Microsoft Storage Spaces SMP is a Win32 service. In Windows 11 it starts only if the user, an application or another service starts it. When the Microsoft Storage Spaces SMP service is started, it logs on as NT AUTHORITY\NetworkService and running in its own process of svchost.exe. If Microsoft Storage Spaces SMP fails to start, the failure details will be recorded into Event Log. Then Windows 11 should boot up and notify the user about the smphost service startup failure.
Dependencies
Microsoft Storage Spaces SMP cannot be started, if the Remote Procedure Call (RPC) service won't start.
Restore Default Startup Configuration of Microsoft Storage Spaces SMP
Before you begin doing this, make sure that all the services on which Microsoft Storage Spaces SMP depends are configured by default and function properly. See the list of dependencies above.1. Run the Command Prompt as an administrator.
2. Copy the command below, paste it into the command window and press ENTER:
sc config smphost start= demand
3. Close the command window and restart the computer.
The smphost service is using the smphost.dll file that is located in the C:\Windows\System32 directory. If the file is removed or corrupted, read this article to restore its original version from Windows 11 installation media.