Remote Procedure Call (RPC) Locator (RpcLocator) Service Defaults in Windows 11
In Windows 2003 and earlier versions of Windows, the Remote Procedure Call (RPC) Locator service manages the RPC name service database. In Windows Vista and later versions of Windows, this service does not provide any functionality and is present for application compatibility.
Default Settings
| Startup type: | Manual |
| Display name: | Remote Procedure Call (RPC) Locator |
| Service name: | RpcLocator |
| Service type: | own |
| Error control: | normal |
| Object: | NT AUTHORITY\NetworkService |
| Path: | %SystemRoot%\system32\locator.exe |
| Registry key: | HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RpcLocator |
| Privileges: |
|
Default Behavior
Remote Procedure Call (RPC) Locator is a Win32 service. In Windows 11 it starts only if the user, an application or another service starts it. When the Remote Procedure Call (RPC) Locator service is started, it logs on as NT AUTHORITY\NetworkService and running in its own process of locator.exe. If Remote Procedure Call (RPC) Locator fails to start, the failure details will be recorded into Event Log. Then Windows 11 should boot up and notify the user about the RpcLocator service startup failure.
Restore Default Startup Configuration of Remote Procedure Call (RPC) Locator
1. Run the Command Prompt as an administrator.
2. Copy the command below, paste it into the command window and press ENTER:
sc config RpcLocator start= demand
3. Close the command window and restart the computer.
The RpcLocator service is using the locator.exe file that is located in the C:\Windows\system32 directory. If the file is removed or corrupted, read this article to restore its original version from Windows 11 installation media.