Routing and Remote Access (RemoteAccess) Service Defaults in Windows 11
Offers routing services to businesses in local area and wide area network environments.
Default Settings
| Startup type: | Disabled |
| Display name: | Routing and Remote Access |
| Service name: | RemoteAccess |
| Service type: | share |
| Error control: | normal |
| Object: | localSystem |
| Path: | %SystemRoot%\System32\svchost.exe -k netsvcs |
| File: | %SystemRoot%\System32\mprdim.dll |
| Registry key: | HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RemoteAccess |
| Privileges: |
|
Default Behavior
Routing and Remote Access is a Win32 service. In Windows 11 it is disabled. When the Routing and Remote Access service is started, it logs on as localSystem and running in a shared process of svchost.exe. If Routing and Remote Access fails to start, the failure details will be recorded into Event Log. Then Windows 11 should boot up and notify the user about the RemoteAccess service startup failure.
Dependencies
Routing and Remote Access cannot be started, if the following services won't start:
Restore Default Startup Configuration of Routing and Remote Access
Before you begin doing this, make sure that all the services on which Routing and Remote Access depends are configured by default and function properly. See the list of dependencies above.1. Run the Command Prompt as an administrator.
2. Copy the commands below, paste them into the command window and press ENTER:
sc stop RemoteAccess
sc config RemoteAccess start= disabled
3. Close the command window and restart the computer.
The RemoteAccess service is using the mprdim.dll file that is located in the C:\Windows\System32 directory. If the file is removed or corrupted, read this article to restore its original version from Windows 11 installation media.