Downloaded Maps Manager (MapsBroker) Service Defaults in Windows 11
Windows service for application access to downloaded maps. This service is started on-demand by application accessing downloaded maps. Disabling this service will prevent apps from accessing maps.
Default Settings
| Startup type: | Automatic |
| Display name: | Downloaded Maps Manager |
| Service name: | MapsBroker |
| Service type: | own |
| Error control: | normal |
| Group: | NetworkService |
| Object: | NT AUTHORITY\NetworkService |
| Path: | %SystemRoot%\System32\svchost.exe -k NetworkService -p |
| File: | %SystemRoot%\System32\moshost.dll |
| Registry key: | HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MapsBroker |
| Privileges: |
|
Default Behavior
Downloaded Maps Manager is a Win32 service. In Windows 11 it starts automatically during the operating system startup. Then the Downloaded Maps Manager service logs on as NT AUTHORITY\NetworkService and running in its own process of svchost.exe. If Downloaded Maps Manager fails to start, the failure details will be recorded into Event Log. Then Windows 11 should boot up and notify the user about the MapsBroker service startup failure.
Dependencies
Downloaded Maps Manager cannot be started, if the Remote Procedure Call (RPC) service won't start.
Restore Default Startup Configuration of Downloaded Maps Manager
Before you begin doing this, make sure that all the services on which Downloaded Maps Manager depends are configured by default and function properly. See the list of dependencies above.1. Run the Command Prompt as an administrator.
2. Copy the commands below, paste them into the command window and press ENTER:
sc config MapsBroker start= auto
sc start MapsBroker
3. Close the command window and restart the computer.
The MapsBroker service is using the moshost.dll file that is located in the C:\Windows\System32 directory. If the file is removed or corrupted, read this article to restore its original version from Windows 11 installation media.