Windows Camera Frame Server (FrameServer) Service Defaults in Windows 11
Enables multiple clients to access video frames from camera devices.
Default Settings
| Startup type: | Manual |
| Display name: | Windows Camera Frame Server |
| Service name: | FrameServer |
| Service type: | share |
| Error control: | normal |
| Object: | NT AUTHORITY\LocalService |
| Path: | %SystemRoot%\System32\svchost.exe -k Camera |
| File: | %SystemRoot%\system32\FrameServer.dll |
| Registry key: | HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\FrameServer |
Default Behavior
Windows Camera Frame Server is a Win32 service. In Windows 11 it starts only if the user, an application or another service starts it. When the Windows Camera Frame Server service is started, it logs on as NT AUTHORITY\LocalService and running in a shared process of svchost.exe. If Windows Camera Frame Server fails to start, the failure details will be recorded into Event Log. Then Windows 11 should boot up and notify the user about the FrameServer service startup failure.
Dependencies
Windows Camera Frame Server cannot be started, if the Remote Procedure Call (RPC) service won't start.
Restore Default Startup Configuration of Windows Camera Frame Server
Before you begin doing this, make sure that all the services on which Windows Camera Frame Server depends are configured by default and function properly. See the list of dependencies above.1. Run the Command Prompt as an administrator.
2. Copy the command below, paste it into the command window and press ENTER:
sc config FrameServer start= demand
3. Close the command window and restart the computer.
The FrameServer service is using the FrameServer.dll file that is located in the C:\Windows\system32 directory. If the file is removed or corrupted, read this article to restore its original version from Windows 11 installation media.