Megasr Service Defaults in Windows 10
LSI MegaRAID Software RAID Driver by LSI Corporation, Inc.
Default Settings
| Startup type: | Manual |
| Display name: | Megasr |
| Service name: | megasr |
| Service type: | kernel |
| Error control: | normal |
| Group: | SCSI Miniport |
| Path: | %SystemRoot%\System32\drivers\megasr.sys |
| Registry key: | HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\megasr |
Default Behavior
Megasr is a kernel device driver. In Windows 10 it is starting only if the user, an application or another service starts it. If Megasr fails to start, the failure details are being recorded into Event Log. Then Windows 10 will start up and notify the user that the megasr service has failed to start due to the error.
Restore Default Startup Configuration of Megasr
1. Run the Command Prompt as an administrator.
2. Copy the command below, paste it into the command window and press ENTER:
sc config megasr start= demand
3. Close the command window and restart the computer.
The megasr service is using the megasr.sys file that is located in the C:\Windows\System32\drivers directory. If the file is removed or corrupted, read this article to restore its original version from Windows 10 installation media.